Applications

  Plugins

About

Applications (in Repo)

Plugins (in Repo)

Documentation

  Chat

  Forum

  Songs

Home KXStudio > News

KXStudio : News

RSS

> Changes in KXStudio repositories
On 2016-05-06 by falkTX

Hey everyone, just a small heads up about the KXStudio repositories.

If you use Debian Testing or the new Ubuntu 16.04 you probably saw some warnings regarding weak SHA1 keys when checking for updates.
We're aware of this issue and a fix is coming soon, but it will require some changes in the repositories.

First, we'll get rid of the 'lucid' builds and rebuild all of them in the 'trusty' series.
For those of you that were using Debian 6 or something older than Ubuntu 14.04, the repositories will stop working for you later this month.

Second, the gcc5 specific packages will be migrated from 'wily' series to 'xenial'.
This means you'll no longer be able to use the KXStudio repositories if you're running Ubuntu 15.10.
If that's the case for you, please update to 16.04 as soon as possible. Note that 15.10 will be officially end-of-life in 2 months.

And finally, the gcc5 packages will begin using Qt5 instead of Qt4 for some applications.
This will include Carla, Qtractor and the v1 series plugins.
Hopefully this won't break anything, but if it does please let us know.

That's it for now. Have a nice weekend!